ASUS Xtion startup

1 reply [Last post]
Joka
Title: NooBot
Joined: 06/12/2014
Posts:
BotPoints: 5
User offline. Last seen 8 years 9 weeks ago.

Hi,

Has anyone else been working with the Xtion sensor? The problem I've been having deals with the initial startup. Sometimes it starts just fine and works flawlessly. Other times the Link won't see it. I'll get a message like:

1d27/0600@1/4 : FAILED TO SET USB INTERFACE.

Thinking that maybe it's like the Create interface, I put in a wait of 2 to 2.5 seconds but that didn't do anything.

I tried running a loop and sending the depth_open command multiple times (with 50 msec between commands) but that didn't do anything after a 100 attempts.

I tried starting by sending a depth_close command before the depth_open but that didn't work.

When I got the "failed to set USB interface" message, I used the console on the Link and went to the depth sensor page and that displayed valid data so the Link was talking to the Xtion.

What did seem to work (although not 100% of time) was unplugging the depth sensor then plugging it back in and re-issuing the depth_open command. This seems to contradict the material in the workshop slides which said don't unplug the sensor because it would cause the Link to hang.

I've noticed that on power up, it takes the Link awhile to establish communication with the Xtion - what is a normal time frame? I've seen times from a couple of seconds to tens of seconds.

One last observation: If on power up of the Link, the first thing done was to check the depth sensor screen on the console, then when a program is run it always fails on the depth_open command. I've never had it work if I checked to see if the depth sensor was working by using the console screen.

That's it - hope someone out there has had more success with this sensor. When it works, it seems pretty awesome.

JackPonting
Title: NooBot
Joined: 06/28/2022
Posts:
BotPoints: 2
User offline. Last seen 9 weeks 6 days ago.

You have done best job by sharing here details of ASUS Xtion startup. I am very glad to get this stuff. Thanks. - http://www.qualitydissertation.co.uk/