Camera Doesn't Work

5 replies [Last post]
henryfrank333
Title: NooBot
Joined: 05/24/2013
Posts:
BotPoints: 7
User offline. Last seen 9 years 16 weeks ago.

Hi all,

I am currently having a ton of trouble getting the USB camera to run on the CBC V2. Whenever I go to vision, I just get a black screen in the view box even with the camera plugged in. Sometimes I get a lot of strange multi-colored lines in the box, but no vision, so I can't get any of the color tracking to work.

Please help! :(

EDIT: (reply to Jeremy. Reply function wasn't working):

Yes, I am. It is black and has an adjustable plug that lets you orient the camera in any direction.

The firmware wasn't ever updated.
OS Vers: 1.7.1
UH Vers: 2.0
FW Vers: 217

The camera used to work without any issue and it stopped all of a sudden for no reason.

Thank you for the help!

EDIT 2: Unfortunately, the reply still isn't working for me, so here is anther addition in response to Jeremy's firmware update recommendation:

Sorry it has been so long since I posted about this, I have been away this past week. Unfortunately, I tried to reinstall the firmware and while the installation all went very smoothly, it still didn't fix the problem and the camera is still showing up as being black/no image.

When I just get the tracking screen loaded up I have random and multi-colored lines all over the screen, but once I plug the camera in, it just all goes black. I mess with the settings and nothing.... :(

Any other thoughts please? I don't even know how I can see if the camera is broken and also where I can get a new one.

Is there a way to use a different usb camera?

Thank you so much!

Jeremy Rand
Jeremy Rand's picture
Title: Botball Youth Advisory Council
Joined: 04/03/2009
Posts:
BotPoints: 1168
User offline. Last seen 7 years 18 weeks ago.

What CBC firmware are you on? Is the camera plugged into the CBC when the CBC boots? You're using the USB webcam which was distributed in the 2009-2012 kits, correct?

-Jeremy Rand
Senior Programmer, Team SNARC (2012-2013), Norman Advanced (2010-2011), Norman HS (2008-2009), Norman North (2005-2007), Whittier MS (2003-2004)
2012-2013 VP of Tech, 2011 President, Botball YAC (2009-2013)
Mentor, Alcott and Whittier MS

henryfrank333
Title: NooBot
Joined: 05/24/2013
Posts:
BotPoints: 7
User offline. Last seen 9 years 16 weeks ago.

Yes, I am. It is black and has an adjustable plug that lets you orient the camera in any direction.

The firmware wasn't ever updated.
OS Vers: 1.7.1
UH Vers: 2.0
FW Vers: 217

The camera used to work without any issue and it stopped all of a sudden for no reason.

Thank you for the help!

Jeremy Rand
Jeremy Rand's picture
Title: Botball Youth Advisory Council
Joined: 04/03/2009
Posts:
BotPoints: 1168
User offline. Last seen 7 years 18 weeks ago.

Can you try upgrading the firmware using the 2.3.1 userhook? If that doesn't fix it, then try the 3.0.3 userhook. Both of those userhooks as well as installation instructions are at http://www.kipr.org/cbc-interface .

(By the way, sorry about the replies not showing up, the forum's spam filter flagged your post for manual review for some reason... no idea why it thought your post was spam. They should be visible now.)

-Jeremy Rand
Senior Programmer, Team SNARC (2012-2013), Norman Advanced (2010-2011), Norman HS (2008-2009), Norman North (2005-2007), Whittier MS (2003-2004)
2012-2013 VP of Tech, 2011 President, Botball YAC (2009-2013)
Mentor, Alcott and Whittier MS

henryfrank333
Title: NooBot
Joined: 05/24/2013
Posts:
BotPoints: 7
User offline. Last seen 9 years 16 weeks ago.

Sorry it has been so long since I posted about this, I have been away this past week. Unfortunately, I tried to reinstall the firmware and while the installation all went very smoothly, it still didn't fix the problem and the camera is still showing up as being black/no image.

When I just get the tracking screen loaded up I have random and multi-colored lines all over the screen, but once I plug the camera in, it just all goes black. I mess with the settings and nothing.... :(

Any other thoughts please? I don't even know how I can see if the camera is broken and also where I can get a new one.

Is there a way to use a different usb camera?

Thank you so much!

Jeremy Rand
Jeremy Rand's picture
Title: Botball Youth Advisory Council
Joined: 04/03/2009
Posts:
BotPoints: 1168
User offline. Last seen 7 years 18 weeks ago.

Unfortunately I think the CBC-compatible cameras were discontinued and are difficult to find now. You might try seeing if a Botball team would be willing to sell you one, seeing as they're not used in the Botball kit anymore. And yeah, there's a decent chance that your camera is broken, but I'm not sure. You could try calling the KIPR office to see if they have suggestions.

-Jeremy Rand
Senior Programmer, Team SNARC (2012-2013), Norman Advanced (2010-2011), Norman HS (2008-2009), Norman North (2005-2007), Whittier MS (2003-2004)
2012-2013 VP of Tech, 2011 President, Botball YAC (2009-2013)
Mentor, Alcott and Whittier MS